Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

Error when trying to use FTP

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
1DumSpark
Advanced
Advanced
Posts: 42
Joined: Sun Feb 22, 2015 7:13 pm

Error when trying to use FTP

Post by 1DumSpark »

I have used FTP with SyncBackFree many times, but not recently.

With SyncBackFree v9.2.30.0 (32-bit) on Windows 7 64-bit, I always get the error "Unable to connect: The FTP component could not be created, class not registered." when pressing the "Test FTP Settings" button while creating a new profile.

There is a long GUID listed for the non-registered class, but there is no copy button to copy it, and there's something weird about that message box that prevents it from being picked up by NirSoft's SysExporter (https://www.nirsoft.net/utils/sysexp.html).

Please advise.
1DumSpark
Advanced
Advanced
Posts: 42
Joined: Sun Feb 22, 2015 7:13 pm

Re: Error when trying to use FTP

Post by 1DumSpark »

It looks like post editing functionality has been turned off for these forums. Can you re-enable it?

Also, perhaps you can add a 'Copy to clipboard' button to SyncBackFree's error boxes and/or allow selecting and copying text within the actual error boxes.

I think I've diagnosed the cause of the problem.

I use the portable version of SyncBackFree (thank you having a portable version!).

It looks like you are using wodFtpDLX.dll from Secure Plus in Croatia. The file is detailed here: https://www.weonlydo.com/FtpDLX/Help/wodFtpDLX-Technical-information.html

As expected (and desired), that dll does not get registered in the Windows registry for the portable version. But either SyncBackFree or wodFtpDLX.dll is throwing an error when that dll is not registered.

Okay, you owe me a tall glass of lemonade for figuring this out. Can you fix the issue?
1DumSpark
Advanced
Advanced
Posts: 42
Joined: Sun Feb 22, 2015 7:13 pm

Re: Error when trying to use FTP

Post by 1DumSpark »

Just to help anyone searching the interwebs for this issue, the ClassID of that FTP component is FE5B9A96-B1A7-4E8B-9713-115F51088981.
bragotto
Newbie
Newbie
Posts: 1
Joined: Thu Mar 05, 2020 8:31 am

Re: Error when trying to use FTP

Post by bragotto »

My problem is: I use the "portable" version because on the machine I would like to run it I dont have admisistrative privileges. But without admiinistrative privileges I can't even register the dll manually. Is there a workaround for it?
Post Reply