Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if it is freeware or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need lots of information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

V9 Button Panel Issues

For technical support visit http://support.2brightsparks.com/
Post Reply
ajs
Expert
Expert
Posts: 66
Joined: Sun Oct 25, 2009 8:57 pm

V9 Button Panel Issues

Post by ajs » Thu Jun 20, 2019 9:21 pm

As mention in a previous post there some issues when the button panel is set to the top of the screen. I have a bit more detail hence this new post.

1. When the burger menu is selected the button panel disappears, depending on how you exit the burger menu it may or may not reappear. For example if you press the burger icon then press ‘Profiles’ the button panel remains hidden. Although it is fairly easy to workaround this issue it is very irritating and just doesn’t look good.

2. Occasionally the ribbons appear below the button panel (see below). I can’t reproduce this at will and does not appear to be related to the above issue which was my first thought. I have had this happen several times, twice this evening, and the only thing that appears to in common was that it occurred just after I had run a profile, but as I said I can’t reproduce this at will.


Image 1.png
Image 1.png (29.91 KiB) Viewed 777 times


As I stated in my previous post if the button panel was just another ribbon then it would be a more consistent and avoid special cause handling of the button panel :) .

Andrew.

Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 466
Joined: Thu Sep 18, 2014 2:08 am

Re: V9 Button Panel Issues

Post by Kostas » Fri Jun 21, 2019 2:41 am

Hi,

Thanks for the feedback, we are looking into it.

Regards,
Kostas
[2bs]

Kostas
2BrightSparks Staff
2BrightSparks Staff
Posts: 466
Joined: Thu Sep 18, 2014 2:08 am

Re: V9 Button Panel Issues

Post by Kostas » Fri Jun 21, 2019 3:46 am

We've uploaded a beta version which fixes the first (#1) issue you've reported:

You can download the appropriate installer based on your current bitversion:
32-bit = https://www.2brightsparks.com/assets/software/new/SyncBackPro_Setup.exe
64-bit = https://www.2brightsparks.com/assets/software/new/SyncBackPro64_Setup.exe

Install it over-the-top of your existing installation so it can preserve your current profiles and settings.

As for issue #2, we can't reproduce it so far but we'll keep an eye on it.

Thanks,
Kostas
[2bs]

ajs
Expert
Expert
Posts: 66
Joined: Sun Oct 25, 2009 8:57 pm

Re: V9 Button Panel Issues

Post by ajs » Fri Jun 21, 2019 10:08 pm

The beta fixes the problem in that the button panel now reappears, however it still disappears when the burger menu is selected which in turn causes the whole screen to jump which I personally find very irritating. It doesn’t disappear when it is set to be at the bottom so I see no reason why it should behave differently when it is set to be at the top.

Regarding problem 2 it turns out there is a very easy way to reproduce this, all you need to do is set the button panel to be at the top then exit, when you restart you see the problem. If you then select the burger menu then the normal behaviour is restored. I don’t believe that this is the only way it can occur as I am fairly certain that it has occurred when I haven’t just restarted SyncBack, but at least this a way to reproduce the problem.

Andrew

ajs
Expert
Expert
Posts: 66
Joined: Sun Oct 25, 2009 8:57 pm

Re: V9 Button Panel Issues

Post by ajs » Sun Jun 23, 2019 12:44 am

I have a bit more information regarding reproducing problem 2. It appears that if SyncBack is maximized when you restart the problem will not occur. If you restart not maximized to reproduce the problem and then maximize the problem remains, so it not just a simple case of the problem does not occur when maximized.

Andrew.

ajs
Expert
Expert
Posts: 66
Joined: Sun Oct 25, 2009 8:57 pm

Re: V9 Button Panel Issues

Post by ajs » Wed Jul 03, 2019 1:03 am

I have just download V9.0.7.9 as well fixing these issues it looks and feels so much better and much more consistent.

Thanks for all your efforts.

Andrew.

mickyj
2BrightSparks Staff
2BrightSparks Staff
Posts: 839
Joined: Mon Jan 05, 2004 6:51 pm

Re: V9 Button Panel Issues

Post by mickyj » Wed Jul 03, 2019 7:11 am

Thanks Andrew! On a personal note, I really appreciate the feedback you've given. As always, we're still working on making more improvements and adding more features.

Post Reply