What is the proper use of wildcard?

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE/Lite.
Post Reply
manya2000
Newbie
Newbie
Posts: 1
Joined: Fri Feb 19, 2010 1:51 pm

What is the proper use of wildcard?

Post by manya2000 » Wed May 16, 2018 8:36 pm

I have the following folders:
*\*.dat
*\ABC_1\
*\ABC_1\PAT\
*\ABC_1\PATCH\
*\ABC_2\
*\ABC_2\PAT\
*\ABC_2\PATCH\
*\ABC_3\
*\ABC_3\PAT\
*\ABC_3\PATCH\

I was able to shorten to:
*\*.dat
*\ABC_1\
*\ABC_1\PAT*\
*\ABC_2\
*\ABC_2\PAT*\
*\ABC_3\
*\ABC_3\PAT*\

But if I tried to shorten to the following, it selects ALL folders under ABC_1, ABC_2 and ABC_3 and selects *.dat files in those wrong folders.

*\*.dat
*\ABC*\
*\ABC*\PAT*\

How can I do it so it selects *.dat files under (ABC_1\PAT and ABC_1\PATCH) and (ABC_2\PAT and ABC_2\PATCH) and (ABC_3\PAT and ABC_3\PATCH)

Thanks for your help,
Mario

Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 690
Joined: Mon Apr 13, 2015 6:22 am

Re: What is the proper use of wildcard?

Post by Swapna » Thu May 17, 2018 2:09 am

Hi,

Please try with these inclusion filters ('to files/folders to copy' list) and see if it works:

*\
*\ABC*\PAT*\*.dat

Click on OK button to close the settings page and confirm any questions you may be asked about excluding/including any matching files. However, please note that *\ filter will select all sub-folders on your source (matching or non-matching sub-folders). So, SyncBack may create empty folders on the destination device when the profile is run. But you can avoid this by configure the Decision-Files settings page as follows:

If you are backing-up files from a standard resource (local drive or network drive) then configure the option under:

Modify Profile > Expert > Decision-Files > Folders > "What to do if a directory exists on Source but not on Destination" (first section) to "Do Nothing"

OR if your Source is a non-standard resource (FTP) then configure the second section of the Decision-Files > Folders settings page to "Do Nothing"

Thank you.
  

Post Reply