Before posting, and to avoid disappointment, please read the following:

  • This forum is not for 2BrightSparks to provide technical support. It's primarily for users to help other users. Do not expect 2BrightSparks to answer any question posted to this forum.
  • If you find a bug in any of our software, please submit a support ticket. It does not matter if you are using our freeware, a beta version or you haven't yet purchased the software. We want to know about any and all bugs so we can fix them as soon as possible. We usually need more information and details from you to reproduce bugs and that is better done via a support ticket and not this forum.

SyncBack will not run as scheduled

SyncBackFree is the freeware version of SyncBack. It is *not* an evaluation version of SyncBackPro/SE.
Post Reply
skbrlatech
Newbie
Newbie
Posts: 2
Joined: Thu Dec 15, 2016 5:26 pm

SyncBack will not run as scheduled

Post by skbrlatech »

I have used SyncBack for a few years now on a Win7 machine and love the product but since changing to a Win10 64 bit laptop i cannot get the backups to run as scheduled. i have tried deleting the installed version and installing the latest, which is V7.6.45.0. I've also created new profiles thinking maybe the old ones were corrupt. I only require a document backup onto a a flash drive scheduled daily at 1100 and yes the laptop is on, logged in and the flash drive is accessible. I can manually run the schedule but when i check back a few days later, the 'Next Run' will show the correct date and time (today if not past the scheduled run time) but the Last Successful Run' will be the date and time i ran it manually which may be a few days or a week ago. So it appears the scheduler is updating from day to day but the backup is not done until I run it manually. Suggestions?

Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 951
Joined: Mon Apr 13, 2015 6:22 am

Re: SyncBack will not run as scheduled

Post by Swapna »

Hi,

If you are not using SyncBackFree V7.6.45.0, please download and install the latest version from the link below:

http://www.2brightsparks.com/assets/software/SyncBack_Setup.exe

Do not uninstall and reinstall, or you'll lose your profiles & settings. Just install 'over the top'.

If you still experience issues with the latest release, then please check if there is any errors displayed under Modify > When > Edit Schedule settings page and "Last Scheduled Run Error" column of SyncBackFree's main-interface after the scheduled time has been passed, which might give you some clues to resolve the issue.

In addition, please refer to these two KB articles for the errors that you might encounter when creating or running schedule tasks on Windows 10:

http://support.2brightsparks.com/knowledgebase/articles/934893-the-requested-operation-requires-elevation-0x8007

http://support.2brightsparks.com/knowledgebase/articles/935535--the-system-cannot-find-the-specified-file-error  

Thank you.

skbrlatech
Newbie
Newbie
Posts: 2
Joined: Thu Dec 15, 2016 5:26 pm

Re: SyncBack will not run as scheduled

Post by skbrlatech »

Thanks for the response. As mentioned before I am running V7.6.45.0. I have no errors when I view the Edit Schedule page. Looking at the 'When' page I see that under Status it has 2 statements, 'This task is ready to run at its next scheduled time' and ' The task has not yet run (0x00041303)'.
The two links provided do not appear to be the problem I am experiencing.
The schedule just does not run. The initial request to this forum I submitted was on 12/15 and at that time I ran a manual backup. The dashboard shows that the Last Run was 12/15/16, the Next Run is due 12/24/16 and Last Successful Run 12/15/16. By running the manual backup that indicates that the profile is set correctly and the backup drive is available. I have confirmed that the backup file does not have any changes since the 12/15 manual backup.
Any other suggestions?

Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 951
Joined: Mon Apr 13, 2015 6:22 am

Re: SyncBack will not run as scheduled

Post by Swapna »

Hi,

Please note that we do not have a scheduler in SyncBack. We rely on Windows Task Scheduler (WTS) to trigger our program on the scheduled date/time to run the tasks. When you create a Schedule within a profile, we are only providing a drill-down into the Windows Task Scheduler interface through our program settings interface to facilitate SyncBack users in the creation and configuration of a Scheduled Task.    

Therefore, WTS on your system is responsible for calling SyncBack to execute the profile at the scheduled date/time. But if WTS failed, then the profiles won't run at the scheduled time.  

Can you open the Task Scheduler from control panel and go to SyncBack branch/node. Make sure you expand the tree on the left column until you find SyncBackFree and select the sub-branch (of SyncBack) with your Computer-User Account name to see the Tasks which will be populated on the center pane.

From there, you need to check under the History tab of the profile name (which failed to start) to find out if your profile is running its scheduled tasks properly. If History is disabled, you will need to enable it and reboot and check back (on the History tab of Task Scheduler) again once this scheduled time has passed to see the results, which might give you some clues to resolve the problem.

Thank you.

mam0856
Newbie
Newbie
Posts: 1
Joined: Sun Jan 22, 2017 5:26 pm

Re: SyncBack will not run as scheduled

Post by mam0856 »

You need to make a change to the menu for your profile in windows scheduler. Open windows scheduler and find the profile you need to edit. Open it and scroll to to the profile on right. Right click on that profile under properties and then click on trigger. Hit edit, the edit trigger window will pop up. Put a check mark in the one time circle. Click Ok. Do not change anything else. Your profile will now run all the time with whatever schedule you set up in SyncBack. Make sure you reboot you computer. Your task will now run as scheduled. Windows 10 Annivesarary update broke the scheduler.

MrFormigari
Newbie
Newbie
Posts: 1
Joined: Thu Dec 12, 2019 10:30 pm

Re: SyncBack will not run as scheduled

Post by MrFormigari »

I was having the same problem and I solved it by changing the following information.
Attachments
Captura de tela 2019-12-12 19.28.04.png
Captura de tela 2019-12-12 19.28.04.png (20.45 KiB) Viewed 1911 times

Carrie20
Newbie
Newbie
Posts: 3
Joined: Tue May 26, 2020 7:15 pm

Re: SyncBack will not run as scheduled

Post by Carrie20 »

This is happening to me and has always done. It seems very random whether it bothers to run to the schedule or not. I have selected settings of run whether logged on or not; wake up to run; and , run as soon as possible after scheduled run is missed.
I tried to follow the instructions below to edit the scheduler but under the Trigger tab, there wasn't a circle to be able to: ' Put a check mark in the one time circle.'
What I did notice was that under that under the General tab in the Task Scheduler, it was ticked against only run when user logged on, yet in Sync backup itself, I have it ticked against Run whether user is logged on or not. Could that be the problem?
Do the Task scheduler options have to match those ticked in Sync backup for the schedule to run?

Any help would be most welcome thanks as this has been very frustrating.
Many thanks

equit
Newbie
Newbie
Posts: 4
Joined: Mon May 27, 2019 12:26 pm

Re: SyncBack will not run as scheduled

Post by equit »

I have found the issue.
The user that was running the tasks did not have the proper rights.

See this link to fix it:
https://audministrator.wordpress.com/2017/04/05/windows-task-scheduler-fails-with-error-code-2147943785/

Or if you are running in a domain, go to your domaincontroller and open GPO editor then go to:
Computer - Policies - Windows Settings - Security Settings - Local Policies - User Right Assignment - Log on as batch job
Then add the user there, run a GPUpdate on your server/client which has SBP running and voilá it works like a charm!

Hope this wil help you!

Carrie20
Newbie
Newbie
Posts: 3
Joined: Tue May 26, 2020 7:15 pm

Re: SyncBack will not run as scheduled

Post by Carrie20 »

Thanks very much for your reply.
I'm a single user on my home PC - when I look at Administrative Tools, I don't have the options available to select that were shown on the link you kindly sent.
When I look at the 2nd solution option on your link, when I go to the Task scheduler to try and change the user account under the General tab, it won't let me do that. It shows that it's running from me as the only user.

Any further thoughts would be most welcome

Many thanks

equit
Newbie
Newbie
Posts: 4
Joined: Mon May 27, 2019 12:26 pm

Re: SyncBack will not run as scheduled

Post by equit »

Hey,

Sorry my solution didn't work.
But try the following:

Hit Start -> Type GPEDIT.MSC -> Hit Enter and navigate to where the picture is showing:
https://1drv.ms/u/s!Aobh0Q2AsLnch_l33P8aoEVsl3Yr9Q

Then dubbel click the Log on as batch job.
Click add User or Group and add your local user.

Carrie20
Newbie
Newbie
Posts: 3
Joined: Tue May 26, 2020 7:15 pm

Re: SyncBack will not run as scheduled

Post by Carrie20 »

Hi. Thanks very much for your latest reply. However this option isn't available on my PC that I can find. I have searched a lot! :) I am the sole user and therefore the account controller/administrator, but that computer configuration option isn't in my admin tools list or control panel or Settings to be able to select that batch option you mention. I'm stuck!
Any further help most welcome
Many thanks

mmullins_98
Advanced
Advanced
Posts: 43
Joined: Wed Jun 05, 2019 11:40 am

Re: SyncBack will not run as scheduled

Post by mmullins_98 »

Here are some problems I have had in Windows 10 Version 1909 Task Scheduler & Syncback. Maybe one of these will get you running again.

It appears that any change made to the current schedule then requires a new trigger time (in advance of current time at least 3 minutes) or the task will not run. Check both the date and the time.

Tasks that don't run after reboot may need to be set to run "One Time" instead of daily if repeat is set to indefinite(in Syncback "Schedule, setting, Repeating, Indefinite").

To schedule a profile to only run once at a scheduled time select a Daily profile and enter 0 for the Recur every x days value. (Quote from the Syncback Help)

Run interactively if user logged on: If this checkbox is ticked then the scheduler will run SyncBackFree in the same session as the logged on user. If you are using Windows 10 then it is not recommended that you use this option as it will likely mean the schedule is not run. If this checkbox is not ticked then the scheduler will run SyncBackFree in session 0, i.e. any logged in user will not see SyncBackFree being run. (Quote from the Syncback Help).

Good luck.

Post Reply