How to enable 256-bit Credentials Encryption?

For technical support visit http://support.2brightsparks.com/
John59224
Enthusiastic
Enthusiastic
Posts: 13
Joined: Tue Aug 15, 2017 5:13 am

How to enable 256-bit Credentials Encryption?

Postby John59224 » Tue Sep 26, 2017 5:19 am

I want SBP to protect the sFTP credentials i have stored in my profiles, in a secure, properly encrypted way. ( I dont want to encrypt via using the "Win API", bc it is trivial to access/crack a Win User/admin password).

(also my secondary gmail account credentials that i have stored in SBP for emailing error logs of profiles)

Why?- bc of the increasing sophistication of Ransomware / cryptolocker type viruses and their increasing focus on finding and deleting user backups after encrypting your files. (ie some new ransomware strand grabs my sFTP dst. credentials from the way SBP stores those credentials, and then uses them to delete my sFTP dst. backup files).

my issue:
1st- i check off use 256-bit aes encryption for storing sensitive settings (on the encryption tab of Global settings - see img attached)
2nd- I click Create Key file, at which point it prompts me for my own passphrase (great, all good so far)
3rd- after providing a passphrase, SBP then asks me to OPEN A FILE??? (what?)-- it should be asking me where to save a file (ie where to save my new key file, which will generated/based off the passphrase i just provided). The only way around this OPEN a file dialog i have found, is to right click and choose New -> Text file, then click OPEN on that blank txt file.

4th- after step 3, it now shows the path to my "key file/ new, blank .txt file" , but once i click OK (to global settings), and then re-open Global settings, the path for the "Encryption key for sensitive stored settings" is again blank.. Shouldn't this field now be populated with the path to the key file i "OPENED" in step 3??

What am i missing here, or doing wrong?

(i have read all of SBP documentation and help files on their encryption options, as well as contacted support with questions on it, im still confused or think that the SBP encryption tab doesnt work properly)

thanks

SBPenc.JPG
SBPenc.JPG (32.27 KiB) Viewed 276 times

Swapna
2BrightSparks Staff
2BrightSparks Staff
Posts: 489
Joined: Mon Apr 13, 2015 6:22 am

Re: How to enable 256-bit Credentials Encryption?

Postby Swapna » Wed Sep 27, 2017 8:52 am

Hi,

We released a new SyncBackPro V8 beta version to fix a bug with 256-bit AES encryption (under global settings). Please download and install the beta version from here:

http://www.2brightsparks.com/assets/software/new/SyncBackPro_Setup.exe

Do not uninstall and reinstall, or you'll lose your profiles & settings. Just install 'over the top'.

After upgrading, click on the ‘Create Key File’ button and enter the password when prompted. A ‘New encryption key file’ window will appear, where you need to enter a filename with an extension to store the encryption key (e.g. MyKeyFile.txt) and select location where you want to save the key file. The key file path will be shown in the ‘Encryption key for sensitive stored settings’. Click on OK button to close the settings page and re-open the global settings again to see if it works?

Thank you


Return to “SyncBackPro (commercial)”



Who is online

Users browsing this forum: No registered users and 1 guest