Problem: SBMservice unresponsive

For technical support visit http://support.2brightsparks.com/

Problem: SBMservice unresponsive

Postby hhh » Thu Mar 01, 2012 4:11 pm

I am experiencing a problem where the SBMservice simply stops responding.
In order to connect to the service via the console the service has to be stopped/started.

Only 4 profiles from a single user has run during the time period which the service froze.

The service is running on a clean install of Windows Server 2008 R2 Foundation.

Any ideas?
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby Dave Wilkins » Thu Mar 01, 2012 5:30 pm

Hi

Which versions are you using? If not V1.4 (service) and V2.1 (console), please update to those and try again
Dave Wilkins
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 7875
Joined: Thu Jan 04, 2007 10:02 am

Re: Problem: SBMservice unresponsive

Postby hhh » Thu Mar 01, 2012 8:08 pm

The service is version 1.4.1 and the console version 2.1.1.
When I check the event log there's nothing out of the ordinary.
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby mickyj » Thu Mar 01, 2012 11:17 pm

Have you tried closing just the console and starting it again? i.e. not restarting the service but the console.

When you reconnect with the console, are any error message shown after login in the main window? Are there any error messages in the Service Status display?
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Re: Problem: SBMservice unresponsive

Postby hhh » Fri Mar 02, 2012 8:32 am

I have to force close the Console. At restart I get an error message:
"Error: Unknown Exception: No connection available."

Service has not been restarted.
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby mickyj » Fri Mar 02, 2012 8:59 am

So when you restart the service you can then connect again?

Have you limited the number of sessions, threads, or queue length on the service? Which connection type are you using (http, tcp, or pipe)?

When does the problem occur with the console? e.g. are you leaving the console logged in for a long time and this problem happens when you start using it again? Does it happen after a certain amount of time? At a certain time?
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Re: Problem: SBMservice unresponsive

Postby MonkeyEdit2000 » Sat Mar 03, 2012 12:27 am

Hi, sorry to interject, but I've been experiencing the same issue as well (same error message), albeit with the service installed on a Windows XP 32-bit OS. And, this was only with 4 PCs connected to the service.

I've been connecting with HTTP. I've not been able to determine when the problem occurs. It has been stable for a few days. I was leaving the console logged in for a long time, but I'm still doing that now. It seems to be intermittent for me, and haven't been able to pinpoint when it occurs. But I've always been forced to reboot...restarting the service and closing the console makes no difference for me. I've got a couple of tickets in on it.
MonkeyEdit2000
Newbie
Newbie
 
Posts: 7
Joined: Wed Feb 01, 2012 1:48 am

Re: Problem: SBMservice unresponsive

Postby hhh » Mon Mar 05, 2012 8:44 am

If I restart the service I can connect again after a little while.
I am connecting with HTTP, and have made no changes to sessions, threads or queue length.

In response to MonkeyEdit2000's post - I was running the service on a XP Pro 32bit machine at first and experienced and had to reboot once as well. After that I moved to a 2008 R2 Foundation instead (the service has frozen as before but no reboot have been necessary).
As MonkeyEdit2000 writes, I havent been able to determine when it occurs. I usually leave the console logged in, since it logs me out after a while anyways. It does not, however, seem to matter whether I leave the console logged in or not, the service becomes unresponsive either way.
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby hhh » Mon Mar 05, 2012 8:56 am

Don't know if this information is valuable, but when connecting to the console after a restart, i get a few lines saying:

2012-03-05 09:34:13:Unknown: Exception raised attemting to start listening: 10048
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby mickyj » Mon Mar 05, 2012 9:04 am

Hi, error 10048 is normal. It just means Windows hasn't yet made the port available (it can take several seconds for the port to become available). The SBM Service (the latest version, the one you are using) will keep retrying until it is available.

Thanks for the info. I think we're going to have to add debug output to the service to try and pinpoint where (and why) it is freezing. I'll post to the forum once that new version is available.
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Re: Problem: SBMservice unresponsive

Postby mickyj » Tue Mar 06, 2012 10:41 am

We've uploaded new beta versions to help discover the cause of these freezes:

viewtopic.php?f=27&t=9125
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Re: Problem: SBMservice unresponsive

Postby hhh » Wed Mar 07, 2012 8:24 am

Ticket 9639-6107030357 submitted with logfile attached!

:D
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby mickyj » Wed Mar 07, 2012 8:51 am

For those submitting a debug file, please make sure you can at least login to the server once. If you cannot login that does not mean it is frozen. It means you have other problems, e.g. firewall, wrong connection information on the client, etc.
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Re: Problem: SBMservice unresponsive

Postby hhh » Wed Jul 18, 2012 8:08 am

any developments regarding this issue?

best regards,

henrik
hhh
Advanced
Advanced
 
Posts: 48
Joined: Tue Nov 22, 2011 3:06 pm

Re: Problem: SBMservice unresponsive

Postby mickyj » Wed Jul 18, 2012 8:26 am

Hi Henrik, we've just uploaded new beta versions of the service (V1.5.2.0) & console (V2.2.2.0):

http://www.2BrightSparks.com/assets/sof ... _Setup.exe

http://www.2BrightSparks.com/assets/sof ... _Setup.exe

You must use the latest version SyncBackPro (V6.1.1.22) with this release of the service. I'm hoping you'll get back to us and say there are no more freezes using the new version...
User avatar
mickyj
2BrightSparks Staff
2BrightSparks Staff
 
Posts: 8050
Joined: Mon Jan 05, 2004 6:51 pm
Location: In front of computer

Next

Return to SBM Service and Console

Who is online

Users browsing this forum: No registered users and 0 guests

User Control Panel

Login

Who is online

In total there are 0 users online :: 0 registered, 0 hidden and 0 guests (based on users active over the past 5 minutes)
Most users ever online was 725 on Thu Feb 20, 2014 2:37 pm

Users browsing this forum: No registered users and 0 guests